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1. Scope 
 
This document is intended to detail a typical installation and configuration of the Dialogic® 4000 Media Gateway 
Series if used to interface between a PBX and the Microsoft® Office Communications Server (OCS) application. 
 
2. Configuration Details 
 
Listed below are details of the PBX and gateways used in the testing on which this document is based. 
 
2.1 PBX 
 

PBX Vendor Mitel 

Model(s) SX-2000 Lightware 

Software Version(s) Version 34.2.0.20 

Additional Notes N/A 

 
2.2 Gateway 
 

Gateway Model Dialogic® 4000 Media Gateway Series 

Software Version(s) Dialogic® Diva® System Release software version 8.3.2 build 459 
(formerly called Diva® Server software) 

Dialogic® Diva® SIPcontrol™ Software version 1.6 build 46 
(DSSIPControl.msi) 

Protocol T1 Q.SIG 

 
2.3 System Diagram 
 
The diagram below details the setup used in the testing and creation of this document. In the diagram, the 
abbreviation DMG4000 stands for the Dialogic® 4000 Media Gateway Series and OCS Server stands for 
Microsoft® Office Communications Server (OCS) 2007. 
 



Mitel SX-2000 Lightware 

4 

 
 

3. Prerequisites 
 
3.1 PBX Prerequisites 
 
The PBX must have all supplemental service packages installed for the Q.SIG protocol to operate properly and 
to provide all advanced supplemental services. 
 
3.1.1 PBX Equipment Required 
 
To support the T1 Q.SIG configuration as documented you need a Mitel T1 line card. 
  
3.1.2 PBX Cabling Requirements 
 
The cabling for Q.SIG connections must be CAT5e or better. A standard voice quality cable will not provide the 
desired signal quality and will cause the gateway to have issues establishing a connection on the D-channel. 
 
3.2 Gateway Prerequisites 
 
The gateway needs to support a T1 Q.SIG interface. 
 
4. Summary of Limitations 
 
No limitations noted as of the last update to this document. 
 
 

PBX DMG4000 

T1/E1 

IP LAN 

OCS Server 

OCS Clients
210         211 

TDM Stations
350         351 
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5. Gateway Setup Notes 
 
Steps for setting up the gateway: 
 

1. Configuration of the Dialogic® Diva® Media Board drivers. 
2. Configuration of the Dialogic® Diva® SIPcontrol™ software. 

 
5.1 Dialogic® Diva® Media Board Configuration 
 
The Diva Media Boards are configured in the Dialogic® Diva® Configuration Manager. To open the Configuration 
Manager, click:  
 
Start > Programs > Dialogic Diva > Configuration Manager. 
 
Note: In the Dialogic® Diva® software and documentation, Diva Media Boards are referred to as Diva Server 
adapters. 
 
A screen similar to the one below will appear. 
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Note: The number of TDM circuits varies depending on the used Dialogic® Media Gateway model. 
 
For this setup:  

• Set the property Switch Type to Q-SIG T1. 
• If your PBX does not provide ring tones to callers from TDM, set the property Generate Ring 

Tones to Yes.  
 
To activate the change, click File > Activate. 
 
Make these configuration changes for each TDM circuit you are going to use on the Dialogic® Media Gateway. 
 
5.2 Dialogic® Diva® SIPcontrol™ Software Gateway Application 
 
The Diva SIPcontrol software is configured via the web based interface. To open the web interface, click Start 
> Dialogic Diva > SIPcontrol Configuration.  
 
On the main page, click the SIPControl link to display the different configuration menus.  
The PSTN Interface Configuration section should automatically include all ports detected in the system. 
 
Note: If you do not see any detected ports, you may need to add http://127.0.0.1 as a trusted site. From 
Microsoft® Internet Explorer, click Tools > Internet Options > Security > Trusted Sites. Use 
http://127.0.0.1:10005 to get to the configuration. 
 
In order for the Diva SIPcontrol software to route calls, the proper routes must be created and configured. Each 
route consists of a source interface and a destination interface. PSTN controllers and SIP peers are considered 
either a source interface or a destination interface depending on the call direction. 
 
 
5.2.1 PSTN Interface and Network Interface Configuration 
 
The following is a typical configuration.  
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The Network Interface Configuration will be used by the Diva SIPcontrol software for listening to the 
SIP traffic from Microsoft® Mediation Server. Given that on these gateways the Microsoft® Mediation Server 
component and the Diva SIPcontrol software are running in the same system, you will need to change SIP 
Listen port to 9803 or to an available un-used port. Later during the Microsoft® Mediation Server 
configuration, you will need to set the PSTN Gateway next hop setting to 9803 to match.  
 
5.2.2 SIP Peer Configuration 
 
Create one SIP peer to talk to Microsoft® Mediation Server as shown below. 
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5.2.3 Routing Configuration 
 
In the Routing Configuration section, you must create two routes, one for the inbound direction (TDM to 
IP) and one for the outbound direction (IP to TDM). Once you have created the routes, click the Save button for 
the changes to take effect. 
 

 
 
5.2.4 Number Normalization 
 
The Dialplan Configuration and Address Map Configuration sections are used for manipulating dial 
numbers. For most PBX dialplans, an address map is required. See the following examples. 
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5.2.4.1 Dialplan Configuration Example 
 
To create a dialplan, click Add from the Dialplan Configuration. The following screens show how to set up 
a dialplan for a Microsoft® Office Communications Server (OCS) 2007 application with the following dialplan from 
the PBX. (This may not match to the PBX programming in section 6 and the Setup in section 2.3). 
 
Area code: 716 
Base number: 639 
Extensions: 4 digits 
Access code: 9 
 

 
 
Complete the settings and click OK. 
For the dialplan to be applied to outbound calls, click the Details button of the PSTN controller and configure 
the Address Normalization settings as shown in the screen below. This converts the dialed numbers into 
the format based on the dialplan for the PBX. If the dialed number is for an internal user, it is converted into a 4-
digit extension. If the called number is for a national call, 91 is prepended. Click OK on this page, and Save on 
the next page for the changes to take effect. 
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For the dialplan to be applied to inbound calls, click the Details button of the configured SIP peer and 
configure the Address Normalization settings as in the screen below. This converts the phone number into 
the E.164 format as needed by Microsoft® Office Communications Server 2007. Click OK on this page, and Save 
on the next page for the changes to take effect. 
 

 
 
 
5.2.4.2 Address Map Configuration Example 
 
If the dialplan does not meet your setups special requirements, the Address Map Configuration can be 
used. An address map entry uses regular expressions (RegEx) (so does Microsoft® Office Communications 
Server 2007) for converting the call address format for inbound or/and outbound direction. 
 
Important note before applying regular expression rules in address maps: The call address for outbound calls (IP 
to TDM) includes a “@hostname” part. For example, +17166391234@DMG4000.bufocs.local is the call address, 
not just +17166391234. For inbound calls (TDM to IP), the call address is the called or calling number, with a 
possible prefix “+”, “N”, or “S”. For example, an inbound call has called number 1234 with ISDN type of 
numbering flag set to Subscriber, and the calling number 49715233334444 with ISDN type of numbering flag 
set to International. The called address will be S1234 and the calling address will be +49715233334444.  
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If the ISDN type of numbering flag is set to National, the prefix “N” will be used with the call number. If the type 
is Unknown, no prefix is used. 
 
Outbound call example using address maps:  
 
Microsoft® Office Communications Server 2007 sends the E.164 dial number format to the SIP gateway. Both 
called and calling numbers need to be converted into a format that the PBX can accept. If the same PBX 
dialplan as in the previous section is used, the following conversions are needed. 
 
Calling number From Microsoft® OCS To PBX 
Internal  +1716639xxxx 716639xxxx 
 
Called number From Microsoft® OCS To PBX 
To Internal  +1716639xxxx xxxx 
To National  +1xxxxxxxxxx 91xxxxxxxxxx 
To International  +xxx…xxx +xxx…xxx 
 
Below is RegEx for the conversion tables above. 
 
Sub rule name Expression Format Stop on match 
Calling number ^\+1(716639\d{4}) $1 Not checked 
Called - Internal ^\+1716639(\d{4}) $1 Checked 
Called - National ^\+1 91 Checked 
Called - International ^\+ 9011 Checked 
 
Below are the configured address maps for outbound calls. The order of the below four sub rules and the stop 
on match check mark are relevant:   
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The following screen shows the first sub rule that converts the E.164 calling number into a  
10-digit national number: 
 

 
 
The following screen shows the second sub rule that converts E.164 for the internal called number into a 4-digit 
extension: 
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The following sub rule converts the E.164 national number into a 10-digit national number with prefix 91: 
 

 
 
The following example converts international call numbers: 
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Once an address map rule is created, it can be applied in three different places. To ease the configuration and 
troubleshooting processes, apply the rule on the outbound route as shown below: 
 

 
 
 
Inbound call example using address map: 
 
This example assumes that the PBX sends inbound calls using a 4-digit extension, with the ISDN type of number 
flag set to Subscriber for internal numbers, National for national calls, and International for 
international calls. 
 
Called number From PBX To Microsoft® OCS 
Internal xxxx (with subscriber type of number) +1716639xxxx 
 
Calling number From PBX To Microsoft® OCS 
Calling from internal xxxx (with subscriber type of number) +1716639xxxx 
Calling from national xxxxxxxxxx (with national type of number) +1xxxxxxxxxx 
Calling from international xxx…xxx (with international type of number) +xxx…xxx 
 
Sub rule name Expression  Format Stop on match 
Called ^S(\d{4})$ +1716639$1 Not checked 
Calling - internal ^S(\d{4})$ +1716639$1 Checked 
Calling - national  ^N(\d{10})$ +1$1 Checked 
Calling - international ^\+ + Checked 
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Create an address map named Inbound and its four sub rules as shown below: 
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Apply the address map inbound rule on the inbound route as follows: 
 

 
 
 
5.2.5 Restarting the Dialogic® Diva® SIPcontrol™ Software 
 
Note: A restart of the Diva SIPcontrol software service is needed only if the setting under Network Interface 
is changed.  
 
Save the configuration and restart the Diva SIPcontrol software service for the changes to take effect. To do so, 
click Service Status on the left hand side of the main configuration page, and then click Restart 
SIPcontrol. The Last operation log will show that the service has been stopped and started again. 
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6. PBX Setup Notes  
 
6.1 Mitel SX-2000 Lightware 
 
This section provides information about the Dialogic® 4000 Media Gateway Series PBX administration 
requirements for Mitel SX-2000 Light systems. This information includes: 
 
1. T1 Interface Administration 
2. Configure the Mitel SX-2000 Light for the T1 Q.SIG protocol 
3. Program Automatic Route Selection  
4. Configure T1 protocol on NSU  
 
Note: This document was developed using the Mitel SX-2000 Light system with the following software versions 
and MOSS Options: 
 
1. SX-2000 Lightware Version 34.2.0.20 
2. IMAT Version  7.5.1.4   
3. MOSS Sheet Options: 

  
Description Option Number 
Message Center 31 
MSAN/APNSS 37 
MSDN/DPNSS Data 38 
MSDN/DPNSS Public Net Access 39 
MSDN/DPNSS Voice I 41 
MSDN/DPNSS Voice II 42 
MSDN/DPNSS Voice III 43 
MSDN/DPNSS Voice IV 44 
MSDN/DPNSS Voice V 45 
MSDN/DPNSS Voice VI 46 
QSIG  57 
T1/D4 64 

 
Notes: 
 
• Other software versions may not support certain features specified in this section. 
 
• The terms “Select” and “Set” are used to imply the respective actions of using the arrow keys to highlight the 

specified choice and of typing in the specified value. 
 
• The installation of the T1 board must be validated prior to this configuration. Sometimes this can only be 

done by the switch vendor depending on the administration access capability. 
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6.1.1 T1 Interface Administration 
 
There are three types of T1 interface administration required to properly program the Q.SIG integration on the 
Mitel SX-2000 Light system for the Dialogic® 4000 Media Gateway Series:  
 
• SX-2000 Light Administration,  
• Automatic Route Selection (ARS), and  
• NSU Configurations / IMAT Programming. 
 

6.1.1.1 SX-2000 Light Administration 

Step 1: Log into the Mitel SX-2000 Light system. 

 

 
 
Press [ESC] then [7] to access the Customer Data Entry menu. 
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Select System Forms and press [ESC] then [1] to access the System Forms menu. 
 
Step 2: In the System Forms menu, select Dimension and Feature Select and press [ESC] then [2] to 

edit the Dimension and Feature Selection form. 
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Configure the Dimension and Feature Selection as follows: 
 

 
 
Notes: 
• Parameters not listed below can be left at their default settings. 
• Q.SIG is a purchased option, so please verify that you have purchased Q.SIG before you continue. 
 
• Select Q-SIG, set it to Yes, and press [ENTER]. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the System Forms menu. 
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Step 3: In the System Forms menu, select System Configuration and press [ESC] then [2] to edit the 
System Configuration form. 

 

 
 
Configure the form as follows: 
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• Select the Cabinet number, the Shelf number, and the Slot number in which the T1 Q.SIG line is being 
installed. 

• Set Programmed Card Type to Universal T1 and press [ENTER]. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the System Forms menu. 
 
Step 4: In the System Forms menu, select Class Of Service Options Assignment and press [ESC] 

then [2] to edit the Class Of Service Options Assignment form. 
 

 
 
Configure the form as follows: 
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• Set Class of service number: to an unused class of service number. 
• Press [ESC] then [1] to create the new class of service. 
• Set the following parameters to Yes: 

o ANI/DNIS/ISDN Number Delivery Trunk 
o Call Announce Line 
o Call Forwarding (External Destination) 
o Display ANI/DNIS/ISDN Calling/Called Number 
o Display Caller ID on Multicall/Keylines 
o Handsfree Answerback Allowed 
o Message Waiting – Audible Tone Notification 
o Public Network Access via DPNSS 
o Public Trunk 

• Set Message Waiting – Deactivate on Off-Hook to No. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the System Forms menu. 
• Press [ESC] then [7] to return to the Customer Data Entry interface. 
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Step 5: In the Customer Data Entry menu, select Digital Link Forms and press [ESC] then [1] to 
access the Digital Link Form menu.  

 

 
 
In the Digital Link Forms menu, select Link Descriptor Assignment and press [ESC]  
then [1] to edit the Link Descriptor Assignment form. 
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Configure the form as follows: 
 

 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set Digital Link Descriptor Number to an unused digital link descriptor number. 
• Set Address for Message Control to A.  
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• Set Integrated Digital Access to ISDN Node.  
• Set QSIG Private Network Access to Yes. 
• Set Termination Mode to NT. 
• Set Operation Mode to CSU. 
• Set CSU Tx Line Build-Out (dB.) to 0. 
• Set Extended Super Frame to Yes. 
• Set Inverted D Channel to No. 
• Set Voice Conversion to Invert. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Digital Link Forms menu. 
 
 
Step 6: In the Digital Link Forms menu, select Digital Link Assignment and press [ESC] then [2] to 

edit the Digital Link Assignment form. 
 

 
 
Configure the form as follows: 
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• As Link number select 1, and as Cabinet number, Shlf number, and Slot number select the numbers in 

which the T1 Q.SIG line is being installed. 
• Set Digital Link Descriptor Number to the link descriptor assignment number defined in Step 5 of 

the SX-2000 Light Administration and press [ENTER]. 
• The Text field can be left blank or a description of the link can be entered. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Digital Link Forms menu. 
• Press [ESC] then [7] to return to the Customer Data Entry interface. 
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Step 7: In the Customer Data Entry menu, select System Forms and press [ESC] then [2] to access the 
System Forms menu.  

 

 
 
In the System Forms menu, select System Options Assignment and press [ESC] then [2]  
to edit the System Options Assignment form. 
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Configure the form as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set Route Optimization Network Id to a string of digits that needs to have the same length as the 

phone extension, and press [ENTER]. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the System Forms menu. 
• Press [ESC] then [7] to return to the Customer Data Entry interface 
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Step 8: In the Customer Data Entry menu, select Trunk Forms and press [ESC] then [1] to access the 
Trunk Forms menu.  

 

 
 
In the Trunk Forms menu, select MSDN-DPNSS-DASSII Trunk Circuit Descriptor Assignment and 
press [ESC] then [2] to edit the MSDN-DPNSS-DASSII Trunk Circuit Descriptor Assignment form. 
 
Configure the form as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 
• Set Trunk Circuit Descriptor Number to an unused trunk circuit descriptor number. 
• Set Signaling Protocol to MSDN-DPNSS. 
• Set Dual Seizure Priority to Incoming. 
• Set Far End Connection to Local Office. 
• Set Card Type to Universal T1. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Trunk Forms menu. 
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Step 9: In the Trunk Forms menu, select Trunk Service Assignment and press [ESC] then [2] to edit the 
Trunk Service Assignment form. 

 

 
 
Configure the form as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 
• Select an unused Trunk Service No. 
• Set COS (Class of Service) to the class of service number defined in Step 4 of the SX-2000 Light 

Administration. 
• Set COR (Class of Restriction) to a valid class of restriction number. 
• Set Absorb to 0. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Trunk Forms menu. 
 
Step 10: In the Trunk Forms menu, select Trunk Assignment and press [ESC] then [2] to edit the Trunk 

Assignment form. 
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Configure the form as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Select as Circuit number 1, and as Cabinet number, Shelf number, and Slot number the number in which the 

T1 QSIG line is being installed. 
• Set Trunk Num to an unused trunk number that has at least 22 unused trunk numbers available after it 

(e.g., if you select 100, 101-122 must also be available). 
• Set Trunk Service Number to the trunk service number defined in Step 9 of SX-2000 Light 

Administration. 
• Set Circuit Desc. Number to the circuit descriptor number defined in Step 8 of the SX-2000 Light 

Administration. 
• Set Interconnect Number to a valid interconnect number. 
• Press [ESC] then [2] to define the range programming, a RANGE PROGRAMMING Parameters data entry 

field will appear in the main screen. 
• Set Trunk Num to the trunk number defined earlier in this step, and press [TAB]. 
• Set the Trunk Service Number to 0, and press [TAB].    
• Set Circuit Desc. Number to 0, and press [TAB].  
• Set Interconnect Number to 0, and press [TAB].  
• Set Comp Zone IO to 0, and press [TAB].  
• Set Tenant Number to 0, and press [TAB].  
• Press [ESC] then [2] to define the range programming, a Specify number of lines data entry field will 

appear in the main screen. 
• Set Specify number of lines to 22 and press [ENTER] 
• Press [ESC] then [4] to execute the command. 
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• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Trunk Forms menu. 
 
Step 11: In the Trunk Forms menu, select Trunk Group Assignment and press [ESC] then [2] to edit the 

Trunk Group Assignment form. 
 

 
 
Configure the form as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 
• Set Trunk Group Number to an unused trunk group number. 
• Set Hunt Mode to Terminal. 
• Press [ESC] then [1] to recall a list of members. 
• Set Member # 1 to the first trunk number defined in Step 10 of the SX-2000 Light Administration. 
• Press [ESC] then [2] to define the range programming, RANGE PROGRAMMING Parameters data entry field 

will appear in the main screen. 
• Set Trunk Number to 1, and press [ESC] then [2]. 
• Set Specify number of lines to 22 and press [ENTER].  
• Press [ESC] then [4] to execute the command. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the Trunk Forms menu. 
• Press [ESC] then [7] to return to the Customer Data Entry interface. 
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6.1.1.2 Automatic Route Selection (ARS) 

Step 1: Log into the Mitel SX-2000 Light system. 

 

 
 
Press [ESC] then [7] to access the Customer Data Entry menu. 
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Select Automatic Route Selection Forms and press [ESC] then [1] to access the ARS Forms menu. 
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Step 2: In the ARS menu, select Digital Modification Assignment and press [ESC] then [2] to edit the 
Digital Modification Assignment form. 

 

 
 
Configure the Digital Modification Assignment as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 
• Select an unused digital modification number. 
• Set the Number of Digits to Absorb to 0.  
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the ARS Forms menu. 
 
Step 3: In the ARS menu, select Route Assignment and press [ESC] then [2] to edit the Route 

Assignment form. 
 

 
 
Configure the form as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 
• Select an unused Route Number. 
• Set Trunk Group Number to the trunk group number defined in Step 11 of the SX-2000 Light 

Administration.  
• Set COR Group Number to 1. 
• Set Digit Modification Number to the digital modification number defined in Step 2 of the Automatic 

Route Selection.  
• Set Digits Before Outpulsing to 5. 
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the ARS Forms menu. 
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Step 4: In the ARS menu, select Automatic Route Selection Assignment and press [ESC] then [2] to 
edit the Automatic Route Selection Assignment form. 

 

 
 
Configure the form as follows: 
 

 
 



Mitel SX-2000 Lightware 

44 

Note: Parameters not listed below can be left at their default settings. 
 
• Set Leading Digits to a currently unassigned ARS number.  
• Set Digits Dialed to an unused 2-digit string.  
• Set Number of Digits to Follow to 2.   
• Set Termination Type to Route.   
• Set Termination Number to 2.   
• Press [ESC] then [4] to commit to changes and [ESC] then [1] to confirm the changes. 
• Press [ESC] then [Q] to return to the ARS Forms menu. 
• Continue to press [ESC] then [Q] until you are logged out of the system.  

6.1.1.3 NSU Configuration/IMAT Programming 
 
 
Step 1: Open up IMAT and create a new database as follows: 
 
 

 
 
Select File > New Database. 
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• Select the appropriate version of the database based on the version of Mitel SX-2000 Light Software being 

used. If you use the SX-2000 Light software version 34.2.0.20, select from the dropdown menu under 
ISDN/PRI System the Universal NSU Release 1.5. 

• Click OK to create the new database. 
 
Step 2: Configure the Site Options as follows: 
  
Select Config > System Configuration > Site Options. 
 

 
 
• Under System Type, select Universal NSU. 
• Under Connected Platforms, select SX-2000 Light. 
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• Under Options, select Network-side Interface and Qsig. 
• Click Update and then  Close. 
 
Step 3: Configure the PRI Link Characteristics as follows: 
 
Select Config > System Configuration > PRI Link Characteristics. 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set PRI link number* to the link number in which the T1 Q.SIG is installed. 
• Set Protocol Type to QSIG. 
• Set Protocol Variant to ISO. 
• Set Physical Type to T1/CSU. 
• Select Network-side / Qsig master. 
• Click the Characteristics button. 
• Configure the T1/CSU Characteristics as follows: 
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• Under Line Coding, select B8ZS. 
• Under Framing, select ESF. 
• Under Line Build Out, select 0 dB. 
• Under Invert Data, select Disable. 
• Click Update and Close. 

 
Step 4: Configure the Incoming Call Characteristics as follows: 
 
Select Config > Incoming Call Characteristics. 
 

 
 
• Set PRI link number* to the link number that the T1 QSIG is installed. 
• Set Trunks* to 1-23. 
• Set DDI Delivery to Yes. 
• Set CPN Delivery to Yes. 
• Click Update and Close. 
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Step 5: Configure the Outgoing Call Characteristics as follows: 
 
Select Config > Outgoing Call Characteristics. 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set PRI link number* to the link number on which the T1 Q.SIG is installed. 
• Under Fixed Bearer Capability, set the parameter Voice to Speech. 
• Click Update and Close. 
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Step 6: Configure the Connection to Remote Sites as follows: 
 
Select File > Connect to Remote Site. 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set Connection Medium to Ethernet Network Card. 
• Under Network Settings, enter the IP address of the 3300 Universal NSU (The default value is 

192.168.1.1.). 
• Set Ethernet Remote System to PRI Card / Universal NSU. 
• Click Connect. 
• Click OK at the Connected to remote site dialog box. 
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Step 7: Save the database as follows: 
 
Click File > Save > Database. 
 

 
 
• Set Destinations to PRI Card / Universal NSU. 
• Click Save. 
 
Note: If a dialog box appears stating “Are you sure you want to save this OLDER version of  
IMAT Database? select DO NOT UPGRADE to the latest database Version and  
Save and click OK. 
 

 
 

 
 
Click OK at the Information dialog box stating that the database has been sent. 
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Click Maintenance > Remote Site Reset. 
 

 
 

Click the Reset button. 
 

 
 
Click OK in the Information dialog box stating that IMAT is “Disconnected from remote site.” 
 

 
 
Click OK in the dialog box stating that the remote site is resetting. 
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7. Microsoft® Office Communications Server 2007 (OCS) Setup 
 
 
7.1 Steps for configuring Microsoft® OCS 
 
Normalization rules are used to convert dial numbers into full E.164 formatted numbers. Microsoft® OCS uses 
the standard E.164 format to search for users listed in the Active Directory (AD).  
 
If a Microsoft® OCS user dials an internal extension number (normally 3-5 digits), the normalization rules convert 
it into full E.164 format. These normalization rules should cover dialed digits for internal extensions, local 
numbers, long distance numbers, and international numbers. 
 
To configure Microsoft® OCS, click  
Start > Programs > Administrative Tools > OCS 2007. 
 
On the tree presented in the configuration window, right-click Forest then select Properties and then Voice 
Properties form the menu provided. Edit a location profile as shown in the following example:  
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Click Add or Edit to create or change a particular rule.  
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In this example, when a user dials any 4-digit number, it will be converted to its E.164 equivalent of 
+1716639xxxx and then that number will be searched for in AD. 
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More examples are shown in the following table: 
 

Name Phone Pattern Translation Pattern Comments 

Extensions ^(\d{4})$ +1716639$1 Internal extensions  

Local ^(\d{7})$ +1716$1 Local number 

National ^1(\d*)$ +1$1 Long distance number 

International ^011(\d*) +$1 International number 

 
 
A default route is used to route all calls to Microsoft® Mediation Server. If you need to route some calls to a 
different Microsoft® Mediation Server, configure the Target phone numbers field accordingly. 
 
To configure Microsoft® OCS, click  
Start > Programs > Administrative Tools > OCS 2007. 
 
On the tree presented in the configuration window, right-click Forest then select Properties and then Voice 
Properties form the menu provided. Edit a route as shown in the example below.  
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This entry routes numbers with or without “+” prefix followed by any digits to Microsoft® Mediation Server 
dmg4000.bufocs.local. 
 
Restart the Front End Services for the above changes to take effect, including all normalization rules. This can 
be done from the window Services. 
 
Note: Unless the dialed number from Microsoft® OCS client (such as Microsoft® Office Communicator) is in E.164 
format, Microsoft® OCS must find a normalization rule to convert the dialed number to E.164. If no rule is found 
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or matched, outbound calls will fail. In this case, Dialogic® Diva® Diagnostics trace will not receive an outbound 
SIP message, since the call will not yet have reached the SIP gateway. 
 
 
7.2 Steps for configuring Microsoft® Office Communications Server 2007 (OCS) 

clients  
 
The domain users need to be enabled for making calls through Microsoft® OCS. 
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Under the Communications tab, check the Enable user for Office Communications Server option 
and then click the Configure button. 

 
 
In the above configuration for the hypothetical user Ray Cassick, an inbound PSTN call for 3101 will be 
converted by the Dialogic® Diva® SIPcontrol™ Software to +17166393101 because in the Diva SIPcontrol 
software dialpan in the SIP Peer Configuration section under Address Normalization the: 

• Number format (outbound) is set to International number, and  
• Encoding (outbound) is set to Use type flag.  

 
Microsoft® OCS will ring the user Ray Cassick if he is logged on to Microsoft® OCS from Microsoft® Office 
Communicator or any Microsoft® OCS supported device. 
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8. Microsoft® Mediation Server Installation and Configuration 
 
8.1 Installation 

 
The gateways of the Dialogic® 4000 Media Gateway Series (DMG4000 Gateways) are shipped with pre-installed 
Microsoft® Mediation Server software. You can complete the Microsoft® Mediation Server configuration by 
running Microsoft® Office Communications Server 2007 (OCS) “Setup.exe” in the DMG4000 Gateways. In the 
Microsoft® OCS Deployment Wizard, select Deploy Other Server Roles, then select Deploy Mediation 
Sever. Follow the steps in the Wizard to complete the setup: 
 
Step 1: Install the Microsoft® Mediation Server software. 
 
Step 2: Activate Microsoft® Mediation Server. Use the existing account and enter the password for the service 
account. 
 
Step 3: No action needed. Do this step when the installation is complete. 
 
Step 4: Configure Certificate.  

1. Download the CA certification path for Microsoft® Mediation Server.  
• From Start > Run, enter http://<CA server>/certsrv 
• Select to download a CA certificate, chain or CRL. 
• Click Download CA certificate chain. 
• In File Download, click Save. 

2. Install the certificate chain for the Microsoft® Mediation Server: 
• In the Deployment Wizard, run step 4 again. 
• Select Import a certificate chain from a .p7b file in step 1.  

3. Verify that your CA is in the list of Trusted root CAs: 
• In the Microsoft® Management Console (MMC) snap-in, click Certificates (If not already 

done, add it.) 
• Verify that CA is on the list of trusted CAs as shown in the example below. 
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4. Create the certificate request for the Microsoft® Mediation Server: 
• Run Deployment Wizard, click step 4. 
• Select the option Create a new certificate. 
• Select the option Send the request immediately to an online CA. 
• Complete the settings in the blank. 
• Click Assign to complete the task. 

 
Note: If you receive the error message “certificate expired or is not yet valid” when you click the assign button at 
the end of step 4, check the time/time zone configured for your Microsoft®  Mediation Server is correct, then run 
the Deployment Wizard again or click Certificates in Available tasks in Microsoft® Mediation Server 
MMC snap-in. 
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8.2 Configuration 
 
From the MMC snap-in, right-click the detected Microsoft® Mediation Server and select Properties. 
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Configure the following settings on the General tab:  
 

 
 



Dialogic® 4000 Media Gateway Series Integration Note  

63 

Click the Next Hop Connections tab and configure the following:  
 

 
 
The Port entry under PSTN Gateway Next hop has to match the configuration in the Dialogic® Diva® 
SIPcontrol™ Software under Network Interface Configuration > SIP Listen Port.  
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Click the Certificate tab.  
 

 
 
Select the certificate that will be used to communicate with Microsoft® OCS. Microsoft® Mediation Server will 
need to restart for these changes to properly take effect. 
 
9. Testing the Validation Matrix 
 
The table below shows various test scenarios that are run as typical validation scenarios if the Dialogic® Media 
Gateway is used in a voice messaging situation. The notes column specifies any notable parts of the test. 
 
The test scenarios below assume that all gateway configuration parameters are at their default values. For a 
sample showing call flows and states please consult the Gateway SIP Compatibility Guide. 
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Test 
Number 

Call Scenario Description Notes 

Inbound call scenarios 

1 Direct call from TDM station set to 
Microsoft® OCS client. 

 

2 Direct call from Microsoft® OCS client to 
TDM station set. 

 

 
 
10. Troubleshooting 
 
10.1 Important Debugging Tools 
 

• Ethereal/Wireshark: Can be used to view and analyze the network captures provided by the Dialogic 
gateway diagnostic firmware. 

• Adobe Audition: Can be used to review and analyze the audio extracted from the network captures to 
troubleshoot any audio related issues. 

• Dialogic® Diva® Diagnostics tool: Used to review and analyze all SIP and ISDN traffic that relates to 
calls going into and leaving the Dialogic® 4000 Media Gateway. 

 
10.2 Using the Dialogic® Diva® Diagnostics Tool 

 
Before using the Dialogic® Diva® Diagnostics tool, you would need to enable it by setting the Dialogic® Diva® 
SIPcontrol™ Software debug. To do so, open the Diva SIPcontrol software web interface, click the link System 
Settings, and set Debug Level to Extended. Click the Save button for the changes to take effect. 
 
Now, you can start the Diva Diagnostics tool. To do so, click:  
Start > Programs > Dialogic Diva > Diagnostics. 
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1. Click one line of your Dialogic® Diva® Media Board in the left pane and click  on the toolbar to activate 
the Basic tracing level. This level captures Q.931 ISDN messages.  
 

2. Click CAPI driver in the left pane and activate the Basic tracing level as explained in step 1. 
 

3. Start tracing. To do so, click the start icon  or select the Start Tracing option form the Tracing 
menu. 
 

4. Reproduce the issue. 
 

5. To stop tracing, click the stop icon  on the tool bar or select the Stop Tracing option form the 
Tracing menu. 

 

6. To view your collected trace, click the view icon  on the toolbar or select the View Recorded 
Trace option from the View menu. A notepad window will open with the recorded log. 
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Examples of Dialogic® Diva® Diagnostics traces for an inbound (TDM to IP) call to Microsoft® Office 
Communications Server 2007 (OCS) 
 
Basic notations for reading the trace: 
 

• SIG-R: RX Q.931 ISDN message 
• SIG-X: TX Q.931 ISDN message 
• SIPR: RX SIP message 
• SIPX: TX SIP message 

 
< Below is a RX Q.931 ISDN message for an inbound call > 
… 
9:16:28.431 C  3 21:2389:383 - SIG-R(030) 08 02 00 17 05 04 03 80 90 A2 18 03 A9 83 81 6C 06 01 A0 33 
30 30 32 70 05 C1 35 31 30 31 
                     Q.931  CR0017 SETUP 
                            Bearer Capability 80 90 a2 
                            Channel Id a9 83 81 
                            Calling Party Number 01 a0 '2401' 
                            Called Party Number c1 '5101' 
 
… 

<Below is a TX SIP message with SDP> 
 
9:16:28.431 1 L 12 00010000-SIPX begin to IP:192.168.0.106 port:5060 socket:3 Proto:TCP 
 9:16:28.431 1 L 12 00010000-    >INVITE sip:+17166395101@dmg4000.bufocs.local:5060 SIP/2.0 
 9:16:28.431 1 L 12 00010000-    >Via: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.431 1 L 12 00010000-    >Max-Forwards: 70 
 9:16:28.431 1 L 12 00010000-    >Allow: INVITE,ACK,CANCEL,BYE,OPTIONS,NOTIFY,REFER 
 9:16:28.431 1 L 12 00010000-    >Accept: application/sdp,application/simple-message-summary 
 9:16:28.431 1 L 12 00010000-    >Supported: timer,replaces 
 9:16:28.431 1 L 12 00010000-    >From: "Dialogic Diva SIPcontrol" 
<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.431 1 L 12 00010000-    >To: "Default" <sip:+17166395101@bufocs.local;user=phone> 
 9:16:28.431 1 L 12 00010000-    >Call-ID: 9c046698-730448-17@dmg4000 
 9:16:28.431 1 L 12 00010000-    >CSeq: 1 INVITE 
 9:16:28.431 1 L 12 00010000-    >Min-SE: 90 
 9:16:28.431 1 L 12 00010000-    >Session-Expires: 600;refresher=uac 
 9:16:28.431 1 L 12 00010000-    >Contact: <sip:+17166392401@192.168.0.106:9803> 
 9:16:28.431 1 L 12 00010000-    >Content-Type: application/sdp 
 9:16:28.431 1 L 12 00010000-    >Content-Length: 253 
 9:16:28.431 1 L 12 00010000-    > 
 9:16:28.431 1 L 12 00010000-    >v=0 
 9:16:28.431 1 L 12 00010000-    >o=SIPcontrol 7472200 7472200 IN IP4 192.168.0.106 
 9:16:28.431 1 L 12 00010000-    >s=- 
 9:16:28.431 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:28.431 1 L 12 00010000-    >t=0 0 
 9:16:28.431 1 L 12 00010000-    >m=audio 30060 RTP/AVP 8 0 101 13 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:8 PCMA/8000 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:0 PCMU/8000 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:101 telephone-event/8000 
 9:16:28.431 1 L 12 00010000-    >a=fmtp:101 0-15 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:13 CN/8000 
 9:16:28.431 1 L 12 00010000-    >a=sendrecv 
 9:16:28.431 1 L 12 00010000-SIPX end 
… 
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<Below is a RX SIP message> 
 
9:16:28.431 1 L 12 00010000-SIPR begin (331 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.431 1 L 12 00010000-    >SIP/2.0 100 Trying 
 9:16:28.431 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.431 1 L 12 00010000-    >TO: "Default"<sip:+17166395101@bufocs.local;user=phone> 
 9:16:28.431 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.431 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.431 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.431 1 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.431 1 L 12 00010000-    > 
 9:16:28.431 1 L 12 00010000-SIPR end 
… 
9:16:28.665 0 L 12 00010000-SIPR begin (408 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.665 0 L 12 00010000-    >SIP/2.0 183 Session Progress 
 9:16:28.665 0 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.665 0 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:28.665 0 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.665 0 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.665 0 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.665 0 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.665 0 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:28.665 0 L 12 00010000-    > 
 9:16:28.665 0 L 12 00010000-SIPR end 
… 
9:16:28.869 1 L 12 00010000-SIPR begin (399 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.869 1 L 12 00010000-    >SIP/2.0 180 Ringing 
 9:16:28.869 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.869 1 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:28.869 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.869 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.869 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.869 1 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.869 1 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:28.869 1 L 12 00010000-    > 
 9:16:28.869 1 L 12 00010000-SIPR end 
… 
9:16:30.197 1 L 12 00010000-SIPR begin (836 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:30.197 1 L 12 00010000-    >SIP/2.0 200 OK 
 9:16:30.197 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:30.197 1 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:30.197 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:30.197 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:30.197 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:30.197 1 L 12 00010000-    >CONTACT: 
<sip:dmg4000.BufOCS.local:5060;transport=Tcp;maddr=192.168.0.106> 
 9:16:30.197 1 L 12 00010000-    >CONTENT-LENGTH: 253 
 9:16:30.197 1 L 12 00010000-    >SUPPORTED: 100rel 
 9:16:30.197 1 L 12 00010000-    >CONTENT-TYPE: application/sdp; charset=utf-8 
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 9:16:30.197 1 L 12 00010000-    >ALLOW: UPDATE 
 9:16:30.197 1 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:30.197 1 L 12 00010000-    >ALLOW: Ack, Cancel, Bye,Invite 
 9:16:30.197 1 L 12 00010000-    > 
 9:16:30.197 1 L 12 00010000-    >v=0 
 9:16:30.197 1 L 12 00010000-    >o=- 0 0 IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >s=session 
 9:16:30.197 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >b=CT:1000 
 9:16:30.197 1 L 12 00010000-    >t=0 0 
 9:16:30.197 1 L 12 00010000-    >m=audio 62438 RTP/AVP 8 101 
 9:16:30.197 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >a=rtcp:62439 
 9:16:30.197 1 L 12 00010000-    >a=label:Audio 
 9:16:30.197 1 L 12 00010000-    >a=rtpmap:8 PCMA/8000 
 9:16:30.197 1 L 12 00010000-    >a=rtpmap:101 telephone-event/8000 
 9:16:30.197 1 L 12 00010000-    >a=fmtp:101 0-16 
 9:16:30.197 1 L 12 00010000-    >a=ptime:20 
 9:16:30.197 1 L 12 00010000-SIPR end 
… 

<Bellow is a TX Q.931 ISDN message, after SIP session is established> 
 
9:16:30.212 C  3 21:2391:136 - SIG-X(005) 08 02 80 17 07 
                     Q.931  CR8017 CONN 
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