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1. Scope 
 
This document is intended to detail a typical installation and configuration of the Dialogic® 4000 Media Gateway 
Series if used to interface between a PBX and the Microsoft® Office Communications Server (OCS) application. 
 
2. Configuration Details 
 
Listed below are the specific details of the PBX and gateways used in the testing to construct the following 
documentation. 
 
2.1 PBX 
 

PBX Vendor Mitel 

Model(s) 3300 ICP 

Software Version(s) System Version 5.1.4.8 

Additional Notes N/A 

 
2.2 Gateway 
 

Gateway Model Dialogic 4000 Media Gateway Series 

Software Version(s) Dialogic® Diva® System Release software version 8.3.2 build 459 
(formerly called Diva® Server software) 

Dialogic® Diva® SIPcontrol™ Software version 1.6 build 46 
(DSSIPControl.msi) 

Protocol E1 Q.SIG 

 
2.3 System Diagram 
 
The diagram below details the setup used in the testing and creation of this document. In the diagram, the 
abbreviation DMG4000 stands for the Dialogic® 4000 Media Gateway Series and OCS Server stands for 
Microsoft® Office Communications Server (OCS) 2007. 
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3. Prerequisites 
 
3.1 PBX Prerequisites 
 
The PBX must have all supplemental service packages installed for the Q.SIG protocol to operate properly and 
to provide all advanced supplemental services. 
 
3.1.1 PBX Equipment Required 
 
To support the E1 Q.SIG configuration as documented, you need a Mitel E1 line card. 
  
3.1.2 PBX Cabling Requirements 
 
The cabling for Q.SIG connections must be CAT5e or better. A standard voice quality cable will not provide 
desired signal quality and will cause the gateway to have issues establishing a connection on the D-channel. 
 
3.2 Gateway Prerequisites 
 
The gateway needs to support an E1 Q.SIG interface. 
 
4. Summary of Limitations 
 
No limitations noted as of the last update to this document. 

 
 

PBX DMG4000 

T1/E1

IP LAN 

OCS Server 

OCS Clients 

710         711 

TDM Stations
250         251 
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5. Gateway Setup Notes 
 
Steps for setting up the gateway are: 
 

1. Configuration of the Dialogic® Diva® Media Board drivers. 
2. Configuration of the Diva SIPcontrol software. 

 
5.1 Dialogic® Diva® Media Board Configuration 
 
The Diva Media Boards are configured in the Dialogic® Diva® Configuration Manager. To open the Configuration 
Manager, click:  
 
Start > Programs > Dialogic Diva > Configuration Manager. 
 
Note: In the Dialogic® Diva® software and documentation, Diva Media Boards are referred to as Diva Server 
adapters. 
 
A screen similar to the one below will appear. 
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Note: The number of TDM circuits varies depending on the used Dialogic® Media Gateway model. 
 
For this setup:  

• Set the property Switch Type to Q-SIG T1. 
• If your PBX does not provide ring tones to callers from TDM, set the property Generate Ring 

Tones to Yes.  
 
To activate the change, click File > Activate. 
 
Make these configuration changes for each TDM circuit you are going to use on the Dialogic® Media Gateway. 
 
5.2 Dialogic® Diva® SIPcontrol™ Software Gateway Application 
 
The Diva SIPcontrol software is configured via the web based interface. To open the web interface, click Start 
> Dialogic Diva > SIPcontrol Configuration.  
 
On the main page, click the SIPControl link to display the different configuration menus.  
The PSTN Interface Configuration section should automatically include all ports detected in the system. 
 
Note: If you do not see any detected ports, you may need to add http://127.0.0.1 as a trusted site. From 
Microsoft® Internet Explorer, click Tools > Internet Options > Security > Trusted Sites. Use 
http://127.0.0.1:10005 to get to the configuration. 
 
In order for the Diva SIPcontrol software to route calls, the proper routes must be created and configured. Each 
route consists of a source interface and a destination interface. PSTN controllers and SIP peers are considered 
either a source interface or a destination interface depending on the call direction. 
 
5.2.1 PSTN Interface and Network Interface Configuration 
 
The following is a typical configuration.  
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The Network Interface Configuration will be used by the Diva SIPcontrol software for listening to the 
SIP traffic from Microsoft® Mediation Server. Given that on these gateways the Microsoft® Mediation Server 
component and the Diva SIPcontrol software are running in the same system, you will need to change SIP 
Listen port to 9803 or to an available un-used port. Later during the Microsoft® Mediation Server 
configuration, you will need to set the PSTN Gateway next hop setting to 9803 to match.  
 
5.2.2 SIP Peer Configuration 
 
Create one SIP peer to talk to Microsoft® Mediation Server as shown below. 
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5.2.3 Routing Configuration 
 
In the Routing Configuration section, you must create two routes, one for the inbound direction (TDM to 
IP) and one for the outbound direction (IP to TDM). Once you have created the routes, click the Save button for 
the changes to take effect. 
 

 
 
5.2.4 Number Normalization 
 
The Dialplan Configuration and Address Map Configuration sections are used for manipulating dial 
numbers. For most PBX dialplans, an address map is required. See the following examples. 
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5.2.4.1 Dialplan Configuration Example 
 
To create a dialplan, click Add from the Dialplan Configuration. The following screens show how to set up 
a dialplan for a Microsoft® Office Communications Server (OCS) 2007 application with the following dialplan from 
the PBX. (This may not match to the PBX programming in section 6 and the Setup in section 2.3). 
 
Area code: 716 
Base number: 639 
Extensions: 4 digits 
Access code: 9 
 

 
 
Complete the settings and click OK. 
For the dialplan to be applied to outbound calls, click the Details button of the PSTN controller and configure 
the Address Normalization settings as shown in the screen below. This converts the dialed numbers into 
the format based on the dialplan for the PBX. If the dialed number is for an internal user, it is converted into a 4-
digit extension. If the called number is for a national call, 91 is prepended. Click OK on this page, and Save on 
the next page for the changes to take effect. 
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For the dialplan to be applied to inbound calls, click the Details button of the configured SIP peer and 
configure the Address Normalization settings as in the screen below. This converts the phone number into 
the E.164 format as needed by Microsoft® Office Communications Server 2007. Click OK on this page, and Save 
on the next page for the changes to take effect. 
 

 
 
 
5.2.4.2 Address Map Configuration Example 
 
If the dialplan does not meet your setups special requirements, the Address Map Configuration can be 
used. An address map entry uses regular expressions (RegEx) (so does Microsoft® Office Communications 
Server 2007) for converting the call address format for inbound or/and outbound direction. 
 
Important note before applying regular expression rules in address maps: The call address for outbound calls (IP 
to TDM) includes a “@hostname” part. For example, +17166391234@DMG4000.bufocs.local is the call address, 
not just +17166391234. For inbound calls (TDM to IP), the call address is the called or calling number, with a 
possible prefix “+”, “N”, or “S”. For example, an inbound call has called number 1234 with ISDN type of 
numbering flag set to Subscriber, and the calling number 49715233334444 with ISDN type of numbering flag 
set to International. The called address will be S1234 and the calling address will be +49715233334444.  
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If the ISDN type of numbering flag is set to National, the prefix “N” will be used with the call number. If the type 
is Unknown, no prefix is used. 
 
Outbound call example using address maps:  
 
Microsoft® Office Communications Server 2007 sends the E.164 dial number format to the SIP gateway. Both 
called and calling numbers need to be converted into a format that the PBX can accept. If the same PBX 
dialplan as in the previous section is used, the following conversions are needed. 
 
Calling number From Microsoft® OCS To PBX 
Internal  +1716639xxxx 716639xxxx 
 
Called number From Microsoft® OCS To PBX 
To Internal  +1716639xxxx xxxx 
To National  +1xxxxxxxxxx 91xxxxxxxxxx 
To International  +xxx…xxx +xxx…xxx 
 
Below is RegEx for the conversion tables above. 
 
Sub rule name Expression Format Stop on match 
Calling number ^\+1(716639\d{4}) $1 Not checked 
Called - Internal ^\+1716639(\d{4}) $1 Checked 
Called - National ^\+1 91 Checked 
Called - International ^\+ 9011 Checked 
 
Below are the configured address maps for outbound calls. The order of the below four sub rules and the stop 
on match check mark are relevant:   
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The following screen shows the first sub rule that converts the E.164 calling number into a  
10-digit national number: 
 

 
 
The following screen shows the second sub rule that converts E.164 for the internal called number into a 4-digit 
extension: 
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The following sub rule converts the E.164 national number into a 10-digit national number with prefix 91: 
 

 
 
The following example converts international call numbers: 
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Once an address map rule is created, it can be applied in three different places. To ease the configuration and 
troubleshooting processes, apply the rule on the outbound route as shown below: 
 

 
 
 
Inbound call example using address map: 
 
This example assumes that the PBX sends inbound calls using a 4-digit extension, with the ISDN type of number 
flag set to Subscriber for internal numbers, National for national calls, and International for 
international calls. 
 
Called number From PBX To Microsoft® OCS 
Internal xxxx (with subscriber type of number) +1716639xxxx 
 
Calling number From PBX To Microsoft® OCS 
Calling from internal xxxx (with subscriber type of number) +1716639xxxx 
Calling from national xxxxxxxxxx (with national type of number) +1xxxxxxxxxx 
Calling from international xxx…xxx (with international type of number) +xxx…xxx 
 
Sub rule name Expression  Format Stop on match 
Called ^S(\d{4})$ +1716639$1 Not checked 
Calling - internal ^S(\d{4})$ +1716639$1 Checked 
Calling - national  ^N(\d{10})$ +1$1 Checked 
Calling - international ^\+ + Checked 
 
Create an address map named Inbound and its four sub rules as shown below: 
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Apply the address map inbound rule on the inbound route as follows: 
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5.2.5 Restarting the Dialogic® Diva® SIPcontrol™ Software 
 
Note: A restart of the Diva SIPcontrol software service is needed only if the setting under Network Interface 
is changed.  
 
Save the configuration and restart the Diva SIPcontrol software service for the changes to take effect. To do so, 
click Service Status on the left hand side of the main configuration page, and then click Restart 
SIPcontrol. The Last operation log will show that the service has been stopped and started again. 
 
6. PBX Setup Notes  
 
6.1 Mitel 3300 ICP 
 
This section provides information about the PBX administration requirements for Mitel 3300 ICP systems. This 
information includes: 
 

1. Configure the E1 Interface Administration. 
2. Configure the Mitel 3300 ICP System Controller. 
3. Program the Automatic Route Selection. 
4. Configure the E1 protocol on NSU. 

 
Notes: 

• This document was developed using the Mitel 3300 ICP system and the following software versions: 
ICP Release Software Version 5.1.4.8 and IMAT Version 7.5.1.4. Other software versions may not 
support certain features specified in this section.   

 
• The installation of the E1 board must be validated prior to this configuration. Sometimes this can only be 

done by the switch vendor depending on the administration access capability. 
 

6.1.1 E1 Interface Administration  
 
There are three types of E1 Interface Administration required to properly program the Q.SIG integration on the 
Mitel 3300 ICP system for the Dialogic® 4000 Media Gateway Series:  
 

1. 3300 ICP Administration,  
2. Automatic Route Selection (ARS), and  
3. NSU Configurations / IMAT Programming.   
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6.1.1.1 3300 ICP Administration 

Step 1: Log into the Mitel 3300 ICP system.  

 

 
 
Select the System Administration Tool option. 
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Step 2: Select System Configuration from the Selection drop-down menu to open the Systems 
Configuration browser.  
 

 
 
Step 3: In the System Configuration browser, expand Units/Modules and select Network Services Unit 

Configuration. 
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Select an unused Unit Number and click Change. 
 
Step 4: Configure the Network Services Unit Configuration as follows: 
 

 
 

• Set Unit Type to Primary Network Services Unit. 
• Set Controller Module to the Controller Module Number. 
• Set Port to the port number where the NSU is installed. 
• Set Programmed Type to 3300 Universal NSU.  
• Set Protocol to Universal E1. 
• Click Save. 

 



Dialogic® 4000 Media Gateway Series Integration Note  

21 

Step 5: In the System Configuration browser, expand Trunks and select Class of Service Options 
Assignment. 
 

 
 
Select an unused Class of Service Number and click Change. 
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Step 6: Configure the Class of Service Options Assignment as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
Set the following parameters to Yes: 
• ANI/DNIS/ISDN Number Delivery Trunk 
• Call Announce Line 
• Call Forwarding (External Destination) 
• Call Hold – Retrieve with Hold Key 
• Call Reroute after CFFM to busy Destination 
• Display ANI/DNIS/ISDN Calling/Called Number 
• Display DNIS/Called Number Before Digit Modification 
• Display Dialed Digits During Outgoing Calls 
• Display Held Call ID on Transfer 
• Message Waiting – Audible Tone Notification 
• ONS CLASS/CLIP: Message Waiting Activate/Deactivate 
• ONS CLASS/CLIP: Set 
• Public Network Access via DPNSS 
• Public Network Identity Provided 
• Public Network to Public Network Connection Allowed 
• Public Trunk 
• R2 Call Progress Tone 
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• Third Party Call Forward Follow Me – Accept 
• Third Party Call Forward Follow Me – Allow 
• Trunk Flash Allowed 
 
Step 7: Click Save.  
 
Step 8: Click OK in the following prompt: 
 

 
Step 9: In the System Configuration browser, expand Digital Trunks, then ISDN-PRI, and select Link 
Descriptor Assignment. 
 

 
 
Click Add to create a new entry. 
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Step 10: Configure the Link Descriptor Assignment as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 

• Set Number Field to an unused link descriptor assignment number. 
• Set Address for Message Control to A.  
• Set Integrated Digital Access to ISDN Node.  
• Set Voice Encoding and Data Encoding to ADI. 
• Set QSIG Private Network Access to Yes. 
• Set E1 Only: CRC-4 Enabled to Yes. 
• Set E1 Only: E1 Line Length (Ft.) to 0-133. 
• Set E1 Only: E1 Impednace (Ohms) to 120. 
• Click Save. 
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Step 11: In the System Configuration browser, select Digital Link Assignment. 
 

 
 
Select the link on the NSU on which the E1 Q.SIG line will be installed and click Change. 
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Step 12: Configure the Digital Link Assignment as follows: 
 

 
 

• Set Digital Link Descriptor to the link descriptor assignment number defined  in Step 10 of  
 the 3300 ICP Administration. 

• The Comment field can be left blank, or a description of the link can be entered. 
• Click Save. 
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Step 13: In the System Configuration browser, select MSDN-DPNSS-DASSII Trunk Circuit Descriptor. 
 

 
 
Click Add to create a new entry. 
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Step 14: Configure the MSDN-DPNSS-DASSII Trunk Circuit Descriptor as follows: 
 

 
 

• Set Number to an unused trunk circuit descriptor number. 
• Set Card Type to Universal E1. 
• Set Dual Seizure Priority to Incoming. 
• Set Far End Connection to Local Office. 
• Set Signaling Protocol to MSDN-DPNSS. 
• Set ISDN BRI Mode to <blank entry>. 
• Click Save. 
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Step 15: In the System Configuration browser, select Trunk Service Assignment.  
 

 
 
Select an unused Trunk Service Number and then click Change. 
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Step 16: Configure the Trunk Service Assignment as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 

• Set Release Link Trunk to No. 
• Set Class of Service to the class of service number defined in Step 9 of the 3300 ICP 

Administration. 
• Set Class of Restriction to 1. 
• Set Baud Rate to 300. 
• Set Interceptor Number to 1. 
• Set Dial In Trunks Incoming Digit Modification – Absorb to 0. 
• Click Save. 

 
Step 17: Click OK in the prompt stating the programming is completed. 
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Step 18: In the System Configuration browser, select Digital Trunk Assignment. 
 

 
 
Select the line, where the Circuit number is 1, and where the Cabinet number, the Shelf number, and the 
Slot number are the numbers in which the Q.SIG line is being installed, and click Change. 
 



Mitel 3300 ICP 

32 

Step 19: Configure the Digital Trunk Assignment as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 

• Set Enter the number of records to change to 30. 
• Set Trunk Number:  

� under Change action to Increment. 
� under Value to change to an unused trunk number. 
� under Increment by to 1. 

• Set Trunk Service Number:  
� under Change action to Change all to. 
� under Value to change to the trunk service number defined in Step 16 of the 3300 ICP 

Administration. 
• Set DTS Service Number: under Change action to Leave all unchanged. 
• Set Circuit Descriptor Number:  

� under Change action to Change all to. 
� under Value to change to the circuit descriptor number defined in Step 14 of the 3300 ICP 

Administration. 
• Set Interconnect Number:  

� under Change action to Change all to. 
� under Value to change to a valid inter-connect number. 

• Click Save. 
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Step 20: Click OK on the prompt stating the programming is completed successfully. 
 

 
 
 
 

6.1.1.2 Automatic Route Selection (ARS) 

Step 1: Log into the Mitel 3300 ICP system.  

 

 
 
Click the System Administration Tool option. 
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Step 2: To open the System Administration browser, select System Administration from the Selection 
drop-down menu  
 

 
 

Step 3: In the System Administration browser, expand Automatic Route Selection (ARS) and select 
Trunk Group Assignment. 
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Click Add to create a new entry. 
 
Step 4: Configure the Trunk Group Assignment as follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 

• Set Enter the number of records to change to 1. 
• Set Trunk Group Number: under Value to Add to an unused trunk group  number. 
• Set Hunt Mode to Terminal. 
• Click Save. 
 

Step 5: Click OK in the prompt stating that the new entry was created successfully. 
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Step 6: Under Trunk Group Number, select the trunk group number just created in step 4. Click Add Member 
to create a new member. 
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Step 7: Configure the new member Trunk Group Assignment as follows: 
 

 
 

• Set Enter the number of records to add to 30. 
• Set Trunk Number under Value to Add to the number of the first trunk defined  in Step 17 of  

 the 3300 ICP Administration. 
• Set Trunk Number under Increment by to 1. 
• Click Save. 
 
 

Step 8: Click OK In the prompt stating that the programming was completed successfully. 
 

 
 



Mitel 3300 ICP 

38 

Step 9: In the System Administration browser, select Route Assignment.  
 

 
 
Under Route Number, select an unused route number and click Change. 
 
Step 10: Configure the Route Assignment as follows: 
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Note: Parameters not listed below can be left at their default settings. 
 

• Set Trunk Group Number to an unused trunk group number defined in Step 4 of  the Automatic 
Route Selection. 

• Set COR Group Number to a valid class of restriction number. 
• Set Digit Modification Number to 1.  
• Set Digits Before Outpulsing to 5.  
• Set Compression to Off.  
• Click Save. 

 
Step 11: In the System Administration browser, select ARS Digits Dialed Assignment. Click Add to 
create a new entry. 
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Step 12: Configure the ARS Digits Dialed Assignment as follows: 
 

 
 

• Set Enter the number of records to add to 1. 
• Under Value to Add set: 

� Digits Dialed to the leading digit(s) to be assigned. 
� Number of Digits to Follow to 2. 
� Termination Type to Route. 
� Termination Number to the route number that was defined in Step 10 of the Automatic 

Route Selection. 
• Click Save. 

Step 13: Click OK in the prompt stating that new entry was added successfully. 
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6.1.1.3 NSU Configuration/IMAT Programming 
 
 
Step 1: Open up IMAT and click File > New Database to create a new database: 
 

 
 
Select the appropriate version of the database from the ISDN/PRI System dropdown menu based on the 
criteria in the table below. For example, for ICP software version 5.1.4.8, the Universal NSU Release 1.4 
needs to be selected  

 
Note: IMAT Version 7.5.1.4 is database version backward compatible. 
 

ICP Software Version IMAT Database Version 
Release 3.0 – Release 3.3 PRI 8.0 or NSU 1.1 
Release 4.0 PRI 8.1 or NSU 1.2 
Release 4.1 – Release 5.0 PRI 8.2 or NSU 1.3 
Release 5.1 NSU NSU 1.4 
Release 5.1 PRI PRI 8.2 or NSU 1.3 
Release 5.2 NSU NSU 1.5 
Release 6.0 NSU NSU 1.5 
Release 6.1 NSU NSU 1.5 
Release 6.1 PRI PRI 8.2 or NSU 1.3 
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Step 2: Click Config > System Configuration > Site Options to configure the Site Options: 
 

 
 
• Under System Type, select Universal NSU. 
• Under Connected Platform, select 3300 ICP. 
• Under Options, select Network-side Interface and Qsig. 
• Click Update and then Close. 
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Step 3: Click Config > System Configuration > PRI Link Characteristics to configure the PRI 
Link Characteristics: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set PRI Link Number* to the link number on which Q.SIG is installed. 
• Set Protocol Type to QSIG. 
• Set Protocol Variant to ISO. 
• Set Physical Type to E1/CEPT. 
• Select Network-side / Qsig master. 
• Click the Characteristics button and configure the E1/CEPT Characteristics as follows: 

 
 
• Under CRC4, select Enable. 
• Under ADI, select Enable. 
• Click Update and then Close. 
 
• In the PRI Link Characteristics dialog box, click Update. 
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• The Update Both Links dialog box appears. 
 

 
 
Click Update. 
 
• In the PRI Link Characteristics dialog box, click Close. 
 
Step 4: Click Config > Incoming Call Characteristics to configure the Incoming Call 
Characteristics as follows: 
 

 
 
• Set PRI link number* to the link number that has Q.SIG installed. 
• Set Trunks* to 1-30. 
• Set DDI Delivery to Yes. 
• Set CPN Delivery to Yes. 
• Click Update and then Close. 
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Step 5: Click Config > Outgoing Call Characteristics to configure the outgoing call characteristics as 
follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set PRI link number* to the link number that has Q.SIG installed. 
• Set Voice to Speech. 
• Click Update and then Close. 
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Step 6: Click File > Connect to Remote Site to configure the Connection to Remote Sites as 
follows: 
 

 
 
Note: Parameters not listed below can be left at their default settings. 
 
• Set Connection Medium to Ethernet Network Card. 
• Under Network Settings, enter the IP address of the 3300 Universal NSU. The default address is 

192.168.1.1). 
• Set Ethernet Remote System to PRI Card / Universal NSU. 
• Click Connect. 
• Click OK in the Connected over Ethernet dialog box. 
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Step 7: Click File > Save > Database to save the database as follows: 
 

 
 
• Set Destinations to PRI Card / Universal NSU. 
• Click Save. 
 
Note: If a dialog box appears stating “Are you sure you want to save this OLDER version of IMAT Database?” 
select DO NOT UPGRADE to Latest database Version and Save and click OK. 
 

 
 
The Information dialog box appears.  
 

 
 
Click OK. 
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Click Maintenance > Remote Site Reset. 
 

 
 
Click Reset. 
 

 
 
Click OK in the Information dialog box. 
 

 
 
Click OK in the dialog box that states the remote site is resetting. 
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7. Microsoft® Office Communications Server 2007 (OCS) Setup 
 
 
7.1 Steps for configuring Microsoft® OCS 
 
Normalization rules are used to convert dial numbers into full E.164 formatted numbers. Microsoft® OCS uses 
the standard E.164 format to search for users listed in the Active Directory (AD).  
 
If a Microsoft® OCS user dials an internal extension number (normally 3-5 digits), the normalization rules convert 
it into full E.164 format. These normalization rules should cover dialed digits for internal extensions, local 
numbers, long distance numbers, and international numbers. 
 
To configure Microsoft® OCS, click  
Start > Programs > Administrative Tools > OCS 2007. 
 
On the tree presented in the configuration window, right-click Forest then select Properties and then Voice 
Properties form the menu provided. Edit a location profile as shown in the following example:  
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Click Add or Edit to create or change a particular rule.  
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In this example, when a user dials any 4-digit number, it will be converted to its E.164 equivalent of 
+1716639xxxx and then that number will be searched for in AD. 
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More examples are shown in the following table: 
 

Name Phone Pattern Translation Pattern Comments 

Extensions ^(\d{4})$ +1716639$1 Internal extensions  

Local ^(\d{7})$ +1716$1 Local number 

National ^1(\d*)$ +1$1 Long distance number 

International ^011(\d*) +$1 International number 

 
 
A default route is used to route all calls to Microsoft® Mediation Server. If you need to route some calls to a 
different Microsoft® Mediation Server, configure the Target phone numbers field accordingly. 
 
To configure Microsoft® OCS, click  
Start > Programs > Administrative Tools > OCS 2007. 
 
On the tree presented in the configuration window, right-click Forest then select Properties and then Voice 
Properties form the menu provided. Edit a route as shown in the example below.  
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This entry routes numbers with or without “+” prefix followed by any digits to Microsoft® Mediation Server 
dmg4000.bufocs.local. 
 
Restart the Front End Services for the above changes to take effect, including all normalization rules. This can 
be done from the window Services. 
 
Note: Unless the dialed number from Microsoft® OCS client (such as Microsoft® Office Communicator) is in E.164 
format, Microsoft® OCS must find a normalization rule to convert the dialed number to E.164. If no rule is found 
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or matched, outbound calls will fail. In this case, Dialogic® Diva® Diagnostics trace will not receive an outbound 
SIP message, since the call will not yet have reached the SIP gateway. 
 
 
7.2 Steps for configuring Microsoft® Office Communications Server 2007 (OCS) 

clients  
 
The domain users need to be enabled for making calls through Microsoft® OCS. 
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Under the Communications tab, check the Enable user for Office Communications Server option 
and then click the Configure button. 

 
 
In the above configuration for the hypothetical user Ray Cassick, an inbound PSTN call for 3101 will be 
converted by the Dialogic® Diva® SIPcontrol™ Software to +17166393101 because in the Diva SIPcontrol 
software dialpan in the SIP Peer Configuration section under Address Normalization the: 

• Number format (outbound) is set to International number, and  
• Encoding (outbound) is set to Use type flag.  

 
Microsoft® OCS will ring the user Ray Cassick if he is logged on to Microsoft® OCS from Microsoft® Office 
Communicator or any Microsoft® OCS supported device. 
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8. Microsoft® Mediation Server Installation and Configuration 
 
8.1 Installation 

 
The gateways of the Dialogic® 4000 Media Gateway Series (DMG4000 Gateways) are shipped with pre-installed 
Microsoft® Mediation Server software. You can complete the Microsoft® Mediation Server configuration by 
running Microsoft® Office Communications Server 2007 (OCS) “Setup.exe” in the DMG4000 Gateways. In the 
Microsoft® OCS Deployment Wizard, select Deploy Other Server Roles, then select Deploy Mediation 
Sever. Follow the steps in the Wizard to complete the setup: 
 
Step 1: Install the Microsoft® Mediation Server software. 
 
Step 2: Activate Microsoft® Mediation Server. Use the existing account and enter the password for the service 
account. 
 
Step 3: No action needed. Do this step when the installation is complete. 
 
Step 4: Configure Certificate.  

1. Download the CA certification path for Microsoft® Mediation Server.  
• From Start > Run, enter http://<CA server>/certsrv 
• Select to download a CA certificate, chain or CRL. 
• Click Download CA certificate chain. 
• In File Download, click Save. 

2. Install the certificate chain for the Microsoft® Mediation Server: 
• In the Deployment Wizard, run step 4 again. 
• Select Import a certificate chain from a .p7b file in step 1.  

3. Verify that your CA is in the list of Trusted root CAs: 
• In the Microsoft® Management Console (MMC) snap-in, click Certificates (If not already 

done, add it.) 
• Verify that CA is on the list of trusted CAs as shown in the example below. 
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4. Create the certificate request for the Microsoft® Mediation Server: 
• Run Deployment Wizard, click step 4. 
• Select the option Create a new certificate. 
• Select the option Send the request immediately to an online CA. 
• Complete the settings in the blank. 
• Click Assign to complete the task. 

 
Note: If you receive the error message “certificate expired or is not yet valid” when you click the assign button at 
the end of step 4, check the time/time zone configured for your Microsoft®  Mediation Server is correct, then run 
the Deployment Wizard again or click Certificates in Available tasks in Microsoft® Mediation Server 
MMC snap-in. 
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8.2 Configuration 
 
From the MMC snap-in, right-click the detected Microsoft® Mediation Server and select Properties. 
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Configure the following settings on the General tab. 
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Click the Next Hop Connections tab and configure the following:  
 

 
 
The Port entry under PSTN Gateway Next hop has to match the configuration in the Dialogic® Diva® 
SIPcontrol™ Software under Network Interface Configuration > SIP Listen Port.  
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Click the Certificate tab.  
 

 
 
Select the certificate that will be used to communicate with Microsoft® OCS. Microsoft® Mediation Server will 
need to restart for these changes to properly take effect. 
 
9. Testing the Validation Matrix 
 
The table below shows various test scenarios that are run as typical validation scenarios if the Dialogic® Media 
Gateway is used in a voice messaging situation. The notes column specifies any notable parts of the test. 
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The test scenarios below assume that all gateway configuration parameters are at their default values. For a 
sample showing call flows and states please consult the Gateway SIP Compatibility Guide. 
 
Test 
Number 

Call Scenario Description Notes 

Inbound call scenarios 

1 Direct call from TDM station set to 
Microsoft® OCS client. 

 

2 Direct call from Microsoft® OCS client to 
TDM station set. 

 

 
 
10. Troubleshooting 
 
10.1 Important Debugging Tools 
 

• Ethereal/Wireshark: Can be used to view and analyze the network captures provided by the Dialogic 
gateway diagnostic firmware. 

• Adobe Audition: Can be used to review and analyze the audio extracted from the network captures to 
troubleshoot any audio related issues. 

• Dialogic® Diva® Diagnostics tool: Used to review and analyze all SIP and ISDN traffic that relates to 
calls going into and leaving the Dialogic® 4000 Media Gateway. 

 
10.2 Using the Dialogic® Diva® Diagnostics Tool 

 
Before using the Dialogic® Diva® Diagnostics tool, you would need to enable it by setting the Dialogic® Diva® 
SIPcontrol™ Software debug. To do so, open the Diva SIPcontrol software web interface, click the link System 
Settings, and set Debug Level to Extended. Click the Save button for the changes to take effect. 
 
Now, you can start the Diva Diagnostics tool. To do so, click:  
Start > Programs > Dialogic Diva > Diagnostics. 
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1. Click one line of your Dialogic® Diva® Media Board in the left pane and click  on the toolbar to activate 
the Basic tracing level. This level captures Q.931 ISDN messages.  
 

2. Click CAPI driver in the left pane and activate the Basic tracing level as explained in step 1. 
 

3. Start tracing. To do so, click the start icon  or select the Start Tracing option form the Tracing 
menu. 
 

4. Reproduce the issue. 
 

5. To stop tracing, click the stop icon  on the tool bar or select the Stop Tracing option form the 
Tracing menu. 

 

6. To view your collected trace, click the view icon  on the toolbar or select the View Recorded 
Trace option from the View menu. A notepad window will open with the recorded log. 
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Examples of Dialogic® Diva® Diagnostics traces for an inbound (TDM to IP) call to Microsoft® Office 
Communications Server 2007 (OCS) 

 
 
Basic notations for reading the trace: 
 

• SIG-R: RX Q.931 ISDN message 
• SIG-X: TX Q.931 ISDN message 
• SIPR: RX SIP message 
• SIPX: TX SIP message 

 
< Below is a RX Q.931 ISDN message for an inbound call > 
… 
9:16:28.431 C  3 21:2389:383 - SIG-R(030) 08 02 00 17 05 04 03 80 90 A2 18 03 A9 83 81 6C 06 01 A0 33 
30 30 32 70 05 C1 35 31 30 31 
                     Q.931  CR0017 SETUP 
                            Bearer Capability 80 90 a2 
                            Channel Id a9 83 81 
                            Calling Party Number 01 a0 '2401' 
                            Called Party Number c1 '5101' 
 
… 

<Below is a TX SIP message with SDP> 
 
9:16:28.431 1 L 12 00010000-SIPX begin to IP:192.168.0.106 port:5060 socket:3 Proto:TCP 
 9:16:28.431 1 L 12 00010000-    >INVITE sip:+17166395101@dmg4000.bufocs.local:5060 SIP/2.0 
 9:16:28.431 1 L 12 00010000-    >Via: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.431 1 L 12 00010000-    >Max-Forwards: 70 
 9:16:28.431 1 L 12 00010000-    >Allow: INVITE,ACK,CANCEL,BYE,OPTIONS,NOTIFY,REFER 
 9:16:28.431 1 L 12 00010000-    >Accept: application/sdp,application/simple-message-summary 
 9:16:28.431 1 L 12 00010000-    >Supported: timer,replaces 
 9:16:28.431 1 L 12 00010000-    >From: "Dialogic Diva SIPcontrol" 
<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.431 1 L 12 00010000-    >To: "Default" <sip:+17166395101@bufocs.local;user=phone> 
 9:16:28.431 1 L 12 00010000-    >Call-ID: 9c046698-730448-17@dmg4000 
 9:16:28.431 1 L 12 00010000-    >CSeq: 1 INVITE 
 9:16:28.431 1 L 12 00010000-    >Min-SE: 90 
 9:16:28.431 1 L 12 00010000-    >Session-Expires: 600;refresher=uac 
 9:16:28.431 1 L 12 00010000-    >Contact: <sip:+17166392401@192.168.0.106:9803> 
 9:16:28.431 1 L 12 00010000-    >Content-Type: application/sdp 
 9:16:28.431 1 L 12 00010000-    >Content-Length: 253 
 9:16:28.431 1 L 12 00010000-    > 
 9:16:28.431 1 L 12 00010000-    >v=0 
 9:16:28.431 1 L 12 00010000-    >o=SIPcontrol 7472200 7472200 IN IP4 192.168.0.106 
 9:16:28.431 1 L 12 00010000-    >s=- 
 9:16:28.431 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:28.431 1 L 12 00010000-    >t=0 0 
 9:16:28.431 1 L 12 00010000-    >m=audio 30060 RTP/AVP 8 0 101 13 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:8 PCMA/8000 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:0 PCMU/8000 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:101 telephone-event/8000 
 9:16:28.431 1 L 12 00010000-    >a=fmtp:101 0-15 
 9:16:28.431 1 L 12 00010000-    >a=rtpmap:13 CN/8000 
 9:16:28.431 1 L 12 00010000-    >a=sendrecv 
 9:16:28.431 1 L 12 00010000-SIPX end 
… 
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<Below is a RX SIP message> 
 
9:16:28.431 1 L 12 00010000-SIPR begin (331 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.431 1 L 12 00010000-    >SIP/2.0 100 Trying 
 9:16:28.431 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.431 1 L 12 00010000-    >TO: "Default"<sip:+17166395101@bufocs.local;user=phone> 
 9:16:28.431 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.431 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.431 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.431 1 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.431 1 L 12 00010000-    > 
 9:16:28.431 1 L 12 00010000-SIPR end 
… 
9:16:28.665 0 L 12 00010000-SIPR begin (408 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.665 0 L 12 00010000-    >SIP/2.0 183 Session Progress 
 9:16:28.665 0 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.665 0 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:28.665 0 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.665 0 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.665 0 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.665 0 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.665 0 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:28.665 0 L 12 00010000-    > 
 9:16:28.665 0 L 12 00010000-SIPR end 
… 
9:16:28.869 1 L 12 00010000-SIPR begin (399 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:28.869 1 L 12 00010000-    >SIP/2.0 180 Ringing 
 9:16:28.869 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:28.869 1 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:28.869 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:28.869 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:28.869 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:28.869 1 L 12 00010000-    >CONTENT-LENGTH: 0 
 9:16:28.869 1 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:28.869 1 L 12 00010000-    > 
 9:16:28.869 1 L 12 00010000-SIPR end 
… 
9:16:30.197 1 L 12 00010000-SIPR begin (836 byte) from IP:192.168.0.106 PORT:5060 on socket 3 port 5060 
TCP 
 9:16:30.197 1 L 12 00010000-    >SIP/2.0 200 OK 
 9:16:30.197 1 L 12 00010000-    >FROM: "Dialogic Diva 
SIPcontrol"<sip:+17166392401@192.168.0.106;user=phone>;tag=sipcontrol_2617534104-7668808 
 9:16:30.197 1 L 12 00010000-    >TO: 
Default<sip:+17166395101@bufocs.local;user=phone>;epid=CE4C602FA5;tag=3f5ea65423 
 9:16:30.197 1 L 12 00010000-    >CSEQ: 1 INVITE 
 9:16:30.197 1 L 12 00010000-    >CALL-ID: 9c046698-730448-17@dmg4000 
 9:16:30.197 1 L 12 00010000-    >VIA: SIP/2.0/TCP 192.168.0.106:9803;branch=z9hG4bK2617534104-7603272 
 9:16:30.197 1 L 12 00010000-    >CONTACT: 
<sip:dmg4000.BufOCS.local:5060;transport=Tcp;maddr=192.168.0.106> 
 9:16:30.197 1 L 12 00010000-    >CONTENT-LENGTH: 253 
 9:16:30.197 1 L 12 00010000-    >SUPPORTED: 100rel 
 9:16:30.197 1 L 12 00010000-    >CONTENT-TYPE: application/sdp; charset=utf-8 
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 9:16:30.197 1 L 12 00010000-    >ALLOW: UPDATE 
 9:16:30.197 1 L 12 00010000-    >SERVER: RTCC/3.0.0.0 MediationServer 
 9:16:30.197 1 L 12 00010000-    >ALLOW: Ack, Cancel, Bye,Invite 
 9:16:30.197 1 L 12 00010000-    > 
 9:16:30.197 1 L 12 00010000-    >v=0 
 9:16:30.197 1 L 12 00010000-    >o=- 0 0 IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >s=session 
 9:16:30.197 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >b=CT:1000 
 9:16:30.197 1 L 12 00010000-    >t=0 0 
 9:16:30.197 1 L 12 00010000-    >m=audio 62438 RTP/AVP 8 101 
 9:16:30.197 1 L 12 00010000-    >c=IN IP4 192.168.0.106 
 9:16:30.197 1 L 12 00010000-    >a=rtcp:62439 
 9:16:30.197 1 L 12 00010000-    >a=label:Audio 
 9:16:30.197 1 L 12 00010000-    >a=rtpmap:8 PCMA/8000 
 9:16:30.197 1 L 12 00010000-    >a=rtpmap:101 telephone-event/8000 
 9:16:30.197 1 L 12 00010000-    >a=fmtp:101 0-16 
 9:16:30.197 1 L 12 00010000-    >a=ptime:20 
 9:16:30.197 1 L 12 00010000-SIPR end 
… 

<Bellow is a TX Q.931 ISDN message, after SIP session is established> 
 
9:16:30.212 C  3 21:2391:136 - SIG-X(005) 08 02 80 17 07 
                     Q.931  CR8017 CONN 
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